ソネットを使ったドキュメント作成のコツ.ソネットのモデルや解析結果などのデータを印刷したりレポートにするときのコツを紹介します.

トップ/ サポート/ tips/ データ出力

ソネットのモデルや解析結果を印刷したりレポートにするときのコツを紹介します.

数値出力

ソネットの解析結果をさらに加工する必要がある場合は、数値出力して、他のシミュレータやexcelに渡すと便利です.

emgraphでは、たとえば、 [Output]-[All Curves to Spreadsheet...]というメニューで csvファイルに出力することができます.


また[Output]-[S,Y,Z-Parameter File]は、ほとんどのマイクロ波シミュレータが サポートする形式のファイルを出力します.

emvuの場合は、 [File]-[Export]-[Data]で電流分布を数値出力できます. 解析領域全体の出力と、ある直線に沿ったデータ列のどちらかを選択できます. 出力形式はcsvファイルですが、データ量が非常に大きくなるので excelで開こうとすると、excelの限界を超えることがあります.


プリンタ出力

もちろん印刷出力も可能です.しかし、最終的な結果がプリンタドライバに依存することと、後からコメントを入れたり配布するのに不便なので かなり以前からほとんど使われなくなりました.


画像出力

直接プリンタに印刷する代わりに、画像ファイルを出力する方法がお勧めです. この方法なら、画像ファイルを別のソフトで開いて、コメントや注意書きを加えたり、 ワープロに貼り付けて、長いレポートの挿絵としてつかうにも便利です.

[File]-[export]-[picture...]で画像ファイルを出力できます.


画像キャプチャ

マウスやメニューも含めた画面キャプチャ

この文書のように、サブメニューをマウスで選んでいる様子も含めて 画像キャプチャするフリーソフトがたくさんあります. たとえば、この文書の画像はwinshotでキャプチャして作っています.

Winshotは 窓の杜で紹介されていました.


画像出力の前に

いったん画像ファイルにしてしまえば、あとから画像処理ソフトでさまざまな加工ができます. しかし、最低限のことは画像ファイルを作る前にやっておいたほうが楽です.

ウィンドウの大きさを統一する

画像の大きさがキャプチャするたびにまちまちだと、後でレポートにまとめたときに見苦しいだけでなく、モデルやグラフ同士の比較が難しくなります.たとえば sizerというfree softを使うと、ウィンドウの大きさをきちんと設定できます.

sizerは 窓の杜で紹介されていました.


層別の色分け/材質別色分け

デフォルトだと導体材料別に色分けされて表示されますが、 導体材料の種類が少ないモデルや 層構造が複雑なモデルでは、わかりにくいです.

[View]-[Colors...]ダイアログを開き Color Objects By Levelを選べば

層別の色分けに表示され、層構造がわかりやすくなります.


背景色

デフォルトでは背景色は白です.最終的に紙に印刷する場合はよいのですが、 最近はPowerPointに渡してプロジェクタで表示することの方が多いでしょう.

[View]-[Colors...]ダイアログを開き BackgroundをBlackにします.

こちらの方がくっきり見えます.